RV Tech Savvy: Charging Challenge

You asked MotorHome:

I purchased my first motorhome, a 2011 Roadtrek 210 Simplicity, three years ago with 18,000 miles on the odometer. It now has more than 30,000 miles. It was parked for about three weeks between trips as we scheduled service to fix a few things. The technician went over the RV thoroughly and mentioned that the battery separator was not working; he demonstrated this by the green light on the monitor not lighting up while the engine was running. He also checked with a voltage tester at the battery separator and was able to show that the voltage on the house battery side was lower than the engine battery side while the engine was running. In addition, with the generator running, the charging light on the monitor panel lit up green. He did not have the part on hand, so we deferred service. Realizing we had a trip coming up before we could replace the battery separator, I ordered the part and had planned to install it myself.

I decided to do one last check prior to installing the part and so turned on the engine and everything was normal, including the green light. We took our trip without any problems until the last day. This is when I noticed that, when the engine was at idle, the alternator was putting out about 10 volts with headlights and marker lights on along with the A/C running full force and back-up camera on. The charging indicator (the magical green light) was not on. Once we got on the road, the alternator was putting out its usual 13 to 14 volts and that green light was lit up again. So here is my question: Is it the battery separator or the alternator that is not putting out enough, or is it just normal because of the load on the alternator at idle?

Lisa Shick | Half Moon Bay, California

Our Expert’s Reply:

Your 210 Simplicity came from the factory with an electronic separator and 6-volt AGM batteries. The fact that the light goes on when the engine output is higher tells me that the separator is working properly, as it will shed power from the higher source to the lower source above a set voltage. So, when the motorhome is plugged in, the Tripp Lite inverter/charger is providing multistage charging, in which the voltage is high enough for the separator to close and provide charge voltage to the chassis battery when needed. The same happens when the alternator is charging the starting batteries, and the house batteries reach a certain threshold. With the age of the motorhome, I would recommend having the batteries tested on, preferably, a computerized battery tester. I also suggest measuring voltage output at the alternator, and then measuring voltage at each battery.
Do this at rest, then start the engine and repeat the measurements. Then do it again with all the loads on. If any of the batteries are deeply discharged or sulfated (yes, AGM batteries can sulfate, but must never be given an equalization charge), it’s quite possible that voltage will be lower during initial charging. But if the voltage measured at each battery goes up when the engine is started, it indicates the separator is doing its job.
Alternators provide a variable charge rate based on engine rpm. Dashboard gauges are notoriously inaccurate, but voltage should be well above 10 volts DC at idle and increase to around 13.5 to 14.5 volts at higher engine speeds. Defective batteries may require higher current. If the alternator voltage is low, it should be tested professionally at a repair facility.

1 COMMENT

LEAVE A REPLY

Please enter your comment!
Please enter your name here