RV Tech Savvy: Brake Warning Light

You asked MotorHome:
While I was driving my 2014 Fleetwood Southwind, the parking brake light illuminated. I immediately slowed and pulled on the brake release. Nothing changed, so I pulled over and, with the transmission in park, pulled on the brake release several times. No change. I shut off the engine, went outside for a visual inspection and to smell for hot brakes. Nothing seemed unusual, so I started down the road again. After awhile the brake light illuminated again. After several stops and a lot of looking I realized the brake light was illuminating only after I turned on the headlights. I tested this theory several times over the course of a couple hundred miles. Sure enough, if the headlights are off the brake light stays off. Any thoughts?
Jim Underwood | Via email

Our Expert’s Reply:
From your description, the symptoms should have nothing to do with the actual brake and are likely caused by a faulty ground connection at the instrument cluster, which is causing power to feed back into the lamp when it is seeking a ground route. You’ll need to remove the cluster and check ground connections. Something may be corroded, loose or disconnected. Try temporarily connecting small jumper wires with alligator clips to a clean, known good ground and then to various ground points on the cluster. I suggest referring to a factory wiring diagram.


Got a tech question for MotorHome’s experts? Email [email protected] or write to MotorHome, 2750 Park View Court, Suite 240, Oxnard, CA 93036 (please include your name, city and state).

LEAVE A REPLY

Please enter your comment!
Please enter your name here