<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: https://ogp.me/ns#"> <!--<![endif]-->
<head>
<title>DIY Cargo Bay Maintenance | MotorHome Magazine</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="http://www.motorhome.com/xmlrpc.php" />
<meta property="og:image" content="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning.jpg" /><link rel="icon" type="image/png" href="http://www.motorhome.com/wp-content/uploads/2018/09/MH-favicon-red.ico"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://www.trailerlifemag.com/wp-content/uploads/2016/12/apple-icon-76x76.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://www.trailerlifemag.com/wp-content/uploads/2016/12/apple-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://www.trailerlifemag.com/wp-content/uploads/2016/12/apple-icon-152x152.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://www.trailerlifemag.com/wp-content/uploads/2016/12/apple-icon-114x114.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://www.trailerlifemag.com/wp-content/uploads/2016/12/apple-icon-144x144.png" />

<meta name="description" content="With the right products, tools and a little elbow grease, you can keep motorhome cargo compartments easily accessible for years to come" />
<meta name="keywords" content="rv maintenance,motorhome maintenance,motorhome diy" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.motorhome.com/#organization","url":"http://www.motorhome.com/","name":"MotorHome Magazine","sameAs":[]},{"@type":"WebSite","@id":"http://www.motorhome.com/#website","url":"http://www.motorhome.com/","name":"MotorHome Magazine","publisher":{"@id":"http://www.motorhome.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://www.motorhome.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#webpage","url":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/","inLanguage":"en-US","name":"DIY Cargo Bay Maintenance","isPartOf":{"@id":"http://www.motorhome.com/#website"},"image":{"@type":"ImageObject","@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#primaryimage","url":"http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning.jpg","width":1200,"height":888},"primaryImageOfPage":{"@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#primaryimage"},"datePublished":"2019-09-27T21:24:16+00:00","dateModified":"2019-09-27T21:24:16+00:00","description":"With the right products, tools and a little elbow grease, you can keep motorhome cargo compartments easily accessible for years to come"},{"@type":"Article","@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#article","isPartOf":{"@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#webpage"},"author":{"@id":"http://www.motorhome.com/author/ehubbard/#author"},"headline":"DIY Cargo Bay Maintenance","datePublished":"2019-09-27T21:24:16+00:00","dateModified":"2019-09-27T21:24:16+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#webpage"},"publisher":{"@id":"http://www.motorhome.com/#organization"},"articleSection":"DIY, Motorhome DIY, motorhome maintenance","image":{"@type":"ImageObject","@id":"http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/#primaryimage","url":"http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning.jpg","width":1200,"height":888}},{"@type":"Person","@id":"http://www.motorhome.com/author/ehubbard/#author","name":"E. Don Smith","sameAs":[],"image":{"@type":"ImageObject","@id":"http://www.motorhome.com/#personlogo","url":"http://2.gravatar.com/avatar/e6c4a8594f96fa27e87b4cafeea2dc79?s=96&d=mm&r=g","width":96,"height":96,"caption":"E. Don Smith"}}]}</script>
<link rel="canonical" href="http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="DIY Cargo Bay Maintenance | MotorHome Magazine" />
<meta property="og:description" content="With the right products, tools and a little elbow grease, you can keep motorhome cargo compartments easily accessible for years to come" />
<meta property="og:url" content="http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/" />
<meta property="og:site_name" content="MotorHome Magazine" />
<meta property="og:image" content="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-1024x758.jpg" />
<meta property="article:published_time" content="2019-09-27T21:24:16Z" />
<meta property="article:modified_time" content="2019-09-27T21:24:16Z" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="DIY Cargo Bay Maintenance | MotorHome Magazine" />
<meta name="twitter:description" content="With the right products, tools and a little elbow grease, you can keep motorhome cargo compartments easily accessible for years to come" />
<meta name="twitter:image" content="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-1024x758.jpg" />

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//motorhome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="MotorHome Magazine &raquo; Feed" href="http://www.motorhome.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="MotorHome Magazine &raquo; Comments Feed" href="http://www.motorhome.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="MotorHome Magazine &raquo; DIY Cargo Bay Maintenance Comments Feed" href="http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='http://www.motorhome.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='http://www.motorhome.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='share-this-share-buttons-sticky-css' href='http://www.motorhome.com/wp-content/plugins/sharethis-share-buttons/css/mu-style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='parent-theme-css' href='http://www.motorhome.com/wp-content/themes/Newspaper/style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href="https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.7.3" type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css' href='http://www.motorhome.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='http://www.motorhome.com/wp-content/themes/Newspaper-child/style.css?ver=8.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='http://www.motorhome.com/wp-content/themes/Newspaper/includes/demos/magazine/demo_style.css?ver=8.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='http://www.motorhome.com/wp-includes/css/dashicons.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='http://www.motorhome.com/wp-includes/js/thickbox/thickbox.css?ver=5.2.3' type='text/css' media='all' />
<script type='text/javascript' src='http://www.motorhome.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://www.motorhome.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#property=5d24f9dbb54cea00128f1f6f&#038;product=sticky-share-buttons-wp'></script>
<script type='text/javascript' src='//motorhome.com/wp-content/themes/Newspaper-child/custom-scripts.js?ver=5.2.3'></script>
<script type="text/javascript">
        var ajaxurl = 'http://www.motorhome.com/wp-admin/admin-ajax.php';
        </script>
<link rel='https://api.w.org/' href='http://www.motorhome.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.motorhome.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.motorhome.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Unique Pedigree: Embassy RV PRL Class B' href='http://www.motorhome.com/top-stories/unique-pedigree-embassy-rv-prl-class-b/' />
<link rel='shortlink' href='http://www.motorhome.com/?p=44066' />
<script type="text/javascript">
            function showGallerySatellite(id) {
                var data = {
                        action: 'gallery_display',
                        slideshow: id,
                        postID: 44066                };
                jQuery.post(ajaxurl, data, function(response) {
                        jQuery('.satl-gal-titles .current').removeClass('current');
                        jQuery('.gal'+id).addClass('current');
                        jQuery('.galleries-satl-wrap').html(response);
//                        initslideshow();
                });        
            }
            function showSoloSatellite(id,unique) {
                var data = {
                        action: 'gallery_display',
                        slideshow: id
                };
                jQuery.post(ajaxurl, data, function(response) {
                        jQuery('#splash-satl-wrap-'+unique).html(response);
                });        
            }
        </script>
<script>var category='tech';</script><script>var subcategory='diy';</script><script>var artid='diy-cargo-bay-maintenance';</script> <script>
				window.tdwGlobal = {"adminUrl":"http:\/\/www.motorhome.com\/wp-admin\/","wpRestNonce":"5f3660a7e3","wpRestUrl":"http:\/\/www.motorhome.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.motorhome.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->

<script>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</script>

<style>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</style>
<script> 
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics_debug.js','ga');

  ga('create', 'UA-3792260-26', 'auto');
  ga('send', 'pageview');

  ga('create', 'UA-12837461-21', {'name': 'rollup'});
  ga('rollup.send', 'pageview');
</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://www.motorhome.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.motorhome.com/category/tech/",
                                "name": "Tech"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.motorhome.com/category/tech/diy/",
                                "name": "DIY"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/",
                                "name": "DIY Cargo Bay Maintenance"                                
                            }
                        }    ]
                        }
                       </script> <style type="text/css" id="wp-custom-css">
			@media (max-width: 767px){
.td-header-top-menu-full {
display: block !important;
}
.td-header-sp-top-menu {
display: block!important;
}
}		</style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> <style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-44066 single-format-standard diy-cargo-bay-maintenance global-block-template-1 td-magazine wpb-js-composer js-comp-ver-5.4.7 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.motorhome.com/?feed=atom" title="RSS" aria-label="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-header-menu-main-container"><ul id="menu-header-menu-main" class="td-mobile-main-menu"><li id="menu-item-38764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-38764"><a href="http://www.motorhome.com/category/motorhome-travel/">Travel</a></li>
<li id="menu-item-32072" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-32072"><a href="http://www.motorhome.com/category/tech/">Tech<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="http://www.motorhome.com/category/tech/diy/">DIY</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/tech/quick-tips/">Quick Tips</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/tech/rv-tech-questions/">RV Tech Q&amp;A</a></li>
</ul>
</li>
<li id="menu-item-32071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-children menu-item-32071"><a href="http://www.motorhome.com/category/motorhomes/">Motorhomes &#038; Gear<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="http://www.motorhome.com/category/motorhomes/gear-reviews/">Gear Reviews</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/motorhomes/motorhome-news/">Motorhome News</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/motorhomes/motorhome-gear/">New Gear</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/motorhomes/new-rvs/">New RVs</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/motorhomes/reviews/">Reviews</a></li>
<li id="menu-item-41829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41829"><a href="https://rvbg.motorhome.com">RV Buyers&#8217; Guide Online Search</a></li>
</ul>
</li>
<li id="menu-item-34711" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34711"><a href="#">Dinghy<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-34708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34708"><a href="http://www.motorhome.com/category/dinghy-towing/">Dinghy Towing</a></li>
<li id="menu-item-33070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33070"><a href="http://www.motorhome.com/submit-email-address/">Downloadable Dinghy Guides</a></li>
</ul>
</li>
<li id="menu-item-38757" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38757"><a target="_blank" href="https://w1.buysub.com/pubs/RV/MHM/MHM_Subscriber_12-26-2013.jsp?cds_page_id=153971&#038;cds_mag_code=MHM">Subscribe<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-38758" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38758"><a target="_blank" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=MHM&#038;cds_page_id=153971">MotorHome Magazine</a></li>
<li id="menu-item-38759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38759"><a href="http://www.motorhome.com/enewsletter/">MotorHome ENews!</a></li>
<li id="menu-item-38760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38760"><a target="_blank" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=TLL&#038;cds_page_id=154023">Trailer Life Magazine</a></li>
</ul>
</li>
<li id="menu-item-32070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-children menu-item-32070"><a href="http://www.motorhome.com/category/lifestyle/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="http://www.motorhome.com/category/lifestyle/camp-cooking/">Camp Cooking</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/lifestyle/new-to-rving/">New To RVing</a></li>
<li class="menu-item-0"><a href="http://www.motorhome.com/category/lifestyle/rv-living/">RV Living</a></li>
<li id="menu-item-33064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33064"><a href="http://www.motorhome.com/info/">Product Info</a></li>
</ul>
</li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.motorhome.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">

<div class="td-header-wrap td-header-style-6 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-header-menu" class="top-header-menu"><li id="menu-item-34131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-34131"><a href="http://www.motorhome.com/contact-us/">Contact Us</a></li>
<li id="menu-item-34132" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-34132"><a target="_blank" rel="noopener noreferrer" href="http://www.gsevents.com/">RV Events</a></li>
<li id="menu-item-38453" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-38453"><a target="_blank" rel="noopener noreferrer" href="http://forums.motorhome.com/">RV Forums</a></li>
<li id="menu-item-35842" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-35842"><a target="_blank" rel="noopener noreferrer" href="https://www.goodsam.com/campgrounds-rv-parks/">RV Parks</a></li>
<li id="menu-item-34137" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-34137"><a target="_blank" rel="noopener noreferrer" href="http://rv.campingworld.com/">RVs For Sale</a></li>
<li id="menu-item-34138" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-34138"><a target="_blank" rel="noopener noreferrer" href="http://www.campingworld.com/">Shop For Gear</a></li>
<li id="menu-item-34139" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-34139"><a href="http://www.motorhome.com/article-indexes/">Article Indexes</a></li>
<li id="menu-item-41830" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-41830"><a target="_blank" rel="noopener noreferrer" href="http://www.motorhome.com/motorhome-classified-advertising/">MotorHome Classified Advertising</a></li>
<li id="menu-item-42272" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42272"><a href="https://rvbg.motorhome.com">RV Buyers Guide</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://www.motorhome.com/?feed=atom" title="RSS" aria-label="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span> </div> </div>

</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap ">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.motorhome.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-menu">
<a class="td-mobile-logo td-sticky-mobile" href="http://www.motorhome.com/">
<img src="http://www.motorhome.com/wp-content/uploads/2017/09/MotorHome-logo-white-373x80-300x64.png" alt="MotorHome Magazine" title="MotorHome Magazine - Motorhome Reviews, Tips, RV News, RV Camping and more" />
</a>
<a class="td-header-logo td-sticky-mobile" href="http://www.motorhome.com/">
<img src="http://www.motorhome.com/wp-content/uploads/2017/09/MotorHome-logo-white-373x80-300x64.png" alt="MotorHome Magazine" title="MotorHome Magazine - Motorhome Reviews, Tips, RV News, RV Camping and more" />
<span class="td-visual-hidden">MotorHome Magazine</span>
</a>
</div>
<div class="menu-header-menu-main-container"><ul id="menu-header-menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-38764"><a href="http://www.motorhome.com/category/motorhome-travel/">Travel</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-32072"><a href="http://www.motorhome.com/category/tech/">Tech</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5d8e8338749c2_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5d8e8338749c2"><script>var block_td_uid_1_5d8e8338749c2 = new tdBlock();
block_td_uid_1_5d8e8338749c2.id = "td_uid_1_5d8e8338749c2";
block_td_uid_1_5d8e8338749c2.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"595","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5d8e8338749c2_rand","tdc_css_class":"td_uid_1_5d8e8338749c2_rand","tdc_css_class_style":"td_uid_1_5d8e8338749c2_rand_style"}';
block_td_uid_1_5d8e8338749c2.td_column_number = "3";
block_td_uid_1_5d8e8338749c2.block_type = "td_block_mega_menu";
block_td_uid_1_5d8e8338749c2.post_count = "4";
block_td_uid_1_5d8e8338749c2.found_posts = "633";
block_td_uid_1_5d8e8338749c2.header_color = "";
block_td_uid_1_5d8e8338749c2.ajax_pagination_infinite_stop = "";
block_td_uid_1_5d8e8338749c2.max_num_pages = "159";
tdBlocksArray.push(block_td_uid_1_5d8e8338749c2);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5d8e8338749c2" id="td_uid_2_5d8e8338760ad" data-td_block_id="td_uid_1_5d8e8338749c2" data-td_filter_value="" href="http://www.motorhome.com/category/tech/">All</a><a class="mega-menu-sub-cat-td_uid_1_5d8e8338749c2" id="td_uid_3_5d8e8338760ee" data-td_block_id="td_uid_1_5d8e8338749c2" data-td_filter_value="32" href="http://www.motorhome.com/category/tech/diy/">DIY</a><a class="mega-menu-sub-cat-td_uid_1_5d8e8338749c2" id="td_uid_4_5d8e83387612b" data-td_block_id="td_uid_1_5d8e8338749c2" data-td_filter_value="18" href="http://www.motorhome.com/category/tech/quick-tips/">Quick Tips</a><a class="mega-menu-sub-cat-td_uid_1_5d8e8338749c2" id="td_uid_5_5d8e83387615e" data-td_block_id="td_uid_1_5d8e8338749c2" data-td_filter_value="48" href="http://www.motorhome.com/category/tech/rv-tech-questions/">RV Tech Q&amp;A</a></div></div><div id=td_uid_1_5d8e8338749c2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/" rel="bookmark" class="td-image-wrap" title="DIY Cargo Bay Maintenance"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="cleaning and maintenance of motorhome cargo compartments" title="DIY Cargo Bay Maintenance" /></a></div> <a href="http://www.motorhome.com/category/tech/diy/" class="td-post-category">DIY</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/" rel="bookmark" title="DIY Cargo Bay Maintenance">DIY Cargo Bay Maintenance</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/motorhomes/motorhome-gear/more-features-in-a-nice-cube/" rel="bookmark" class="td-image-wrap" title="More Features in a Nice Cube"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/JWM20-small-4-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/JWM20-small-4-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/JWM20-small-4-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="More Features in a Nice Cube" /></a></div> <a href="http://www.motorhome.com/category/motorhomes/motorhome-gear/" class="td-post-category">New Gear</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/motorhomes/motorhome-gear/more-features-in-a-nice-cube/" rel="bookmark" title="More Features in a Nice Cube">More Features in a Nice Cube</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/top-stories/lifting-the-fog/" rel="bookmark" class="td-image-wrap" title="Lifting the Fog"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/dual-pane-windows-lead1-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/dual-pane-windows-lead1-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/dual-pane-windows-lead1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Motorhome window frames a foggy landscape" title="Lifting the Fog" /></a></div> <a href="http://www.motorhome.com/category/tech/" class="td-post-category">Tech</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/top-stories/lifting-the-fog/" rel="bookmark" title="Lifting the Fog">Lifting the Fog</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/quick-tips/motorhome-quick-tip-ankle-saver/" rel="bookmark" class="td-image-wrap" title="Motorhome Quick Tip: Ankle Saver"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/QT-Ankle-Saver-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/QT-Ankle-Saver-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/QT-Ankle-Saver-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Photos showing use of plywood to cover motorhome stairwell" title="Motorhome Quick Tip: Ankle Saver" /></a></div> <a href="http://www.motorhome.com/category/tech/quick-tips/" class="td-post-category">Quick Tips</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/quick-tips/motorhome-quick-tip-ankle-saver/" rel="bookmark" title="Motorhome Quick Tip: Ankle Saver">Motorhome Quick Tip: Ankle Saver</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5d8e8338749c2" data-td_block_id="td_uid_1_5d8e8338749c2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5d8e8338749c2" data-td_block_id="td_uid_1_5d8e8338749c2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-32071"><a href="http://www.motorhome.com/category/motorhomes/">Motorhomes &#038; Gear</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_5d8e83387842e_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_6_5d8e83387842e"><script>var block_td_uid_6_5d8e83387842e = new tdBlock();
block_td_uid_6_5d8e83387842e.id = "td_uid_6_5d8e83387842e";
block_td_uid_6_5d8e83387842e.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"36","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_6_5d8e83387842e_rand","tdc_css_class":"td_uid_6_5d8e83387842e_rand","tdc_css_class_style":"td_uid_6_5d8e83387842e_rand_style"}';
block_td_uid_6_5d8e83387842e.td_column_number = "3";
block_td_uid_6_5d8e83387842e.block_type = "td_block_mega_menu";
block_td_uid_6_5d8e83387842e.post_count = "4";
block_td_uid_6_5d8e83387842e.found_posts = "2063";
block_td_uid_6_5d8e83387842e.header_color = "";
block_td_uid_6_5d8e83387842e.ajax_pagination_infinite_stop = "";
block_td_uid_6_5d8e83387842e.max_num_pages = "516";
tdBlocksArray.push(block_td_uid_6_5d8e83387842e);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_6_5d8e83387842e" id="td_uid_7_5d8e833879704" data-td_block_id="td_uid_6_5d8e83387842e" data-td_filter_value="" href="http://www.motorhome.com/category/motorhomes/">All</a><a class="mega-menu-sub-cat-td_uid_6_5d8e83387842e" id="td_uid_8_5d8e833879749" data-td_block_id="td_uid_6_5d8e83387842e" data-td_filter_value="112" href="http://www.motorhome.com/category/motorhomes/gear-reviews/">Gear Reviews</a><a class="mega-menu-sub-cat-td_uid_6_5d8e83387842e" id="td_uid_9_5d8e833879788" data-td_block_id="td_uid_6_5d8e83387842e" data-td_filter_value="355" href="http://www.motorhome.com/category/motorhomes/motorhome-news/">Motorhome News</a><a class="mega-menu-sub-cat-td_uid_6_5d8e83387842e" id="td_uid_10_5d8e8338797bc" data-td_block_id="td_uid_6_5d8e83387842e" data-td_filter_value="30" href="http://www.motorhome.com/category/motorhomes/motorhome-gear/">New Gear</a><a class="mega-menu-sub-cat-td_uid_6_5d8e83387842e" id="td_uid_11_5d8e8338797ec" data-td_block_id="td_uid_6_5d8e83387842e" data-td_filter_value="600" href="http://www.motorhome.com/category/motorhomes/new-rvs/">New RVs</a><a class="mega-menu-sub-cat-td_uid_6_5d8e83387842e" id="td_uid_12_5d8e83387981a" data-td_block_id="td_uid_6_5d8e83387842e" data-td_filter_value="461" href="http://www.motorhome.com/category/motorhomes/reviews/">Reviews</a></div></div><div id=td_uid_6_5d8e83387842e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/top-stories/unique-pedigree-embassy-rv-prl-class-b/" rel="bookmark" class="td-image-wrap" title="Unique Pedigree: Embassy RV PRL Class B"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/20190604-Embassy-RV-5-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/20190604-Embassy-RV-5-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/20190604-Embassy-RV-5-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Embassy RV PRL Class B with the Optional add-a-room vinyl tent attached to the back" title="Unique Pedigree: Embassy RV PRL Class B" /></a></div> <a href="http://www.motorhome.com/category/motorhomes/new-rvs/" class="td-post-category">New RVs</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/top-stories/unique-pedigree-embassy-rv-prl-class-b/" rel="bookmark" title="Unique Pedigree: Embassy RV PRL Class B">Unique Pedigree: Embassy RV PRL Class B</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/motorhomes/motorhome-gear/more-features-in-a-nice-cube/" rel="bookmark" class="td-image-wrap" title="More Features in a Nice Cube"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/JWM20-small-4-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/JWM20-small-4-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/JWM20-small-4-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="More Features in a Nice Cube" /></a></div> <a href="http://www.motorhome.com/category/motorhomes/motorhome-gear/" class="td-post-category">New Gear</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/motorhomes/motorhome-gear/more-features-in-a-nice-cube/" rel="bookmark" title="More Features in a Nice Cube">More Features in a Nice Cube</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/motorhomes/motorhome-gear/kijaro-rocks-your-campfire-with-comfort-and-style/" rel="bookmark" class="td-image-wrap" title="Kijaro Rocks Your Campfire with Comfort and Style"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/Kijaro-Lok-it-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/Kijaro-Lok-it-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/Kijaro-Lok-it-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Kijaro folding rocking chair" title="Kijaro Rocks Your Campfire with Comfort and Style" /></a></div> <a href="http://www.motorhome.com/category/motorhomes/motorhome-gear/" class="td-post-category">New Gear</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/motorhomes/motorhome-gear/kijaro-rocks-your-campfire-with-comfort-and-style/" rel="bookmark" title="Kijaro Rocks Your Campfire with Comfort and Style">Kijaro Rocks Your Campfire with Comfort and Style</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/motorhomes/new-rvs/cool-new-pop-top-class-b/" rel="bookmark" class="td-image-wrap" title="Cool New Pop-Top Class B"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/Solis-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/Solis-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/Solis-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Winnebago Solis Class B motorhome" title="Cool New Pop-Top Class B" /></a></div> <a href="http://www.motorhome.com/category/motorhomes/new-rvs/" class="td-post-category">New RVs</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/motorhomes/new-rvs/cool-new-pop-top-class-b/" rel="bookmark" title="Cool New Pop-Top Class B">Cool New Pop-Top Class B</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_5d8e83387842e" data-td_block_id="td_uid_6_5d8e83387842e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_6_5d8e83387842e" data-td_block_id="td_uid_6_5d8e83387842e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-41829"><a href="https://rvbg.motorhome.com">RV Buyers&#8217; Guide Online Search</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-34711"><a href="#">Dinghy</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-34708"><a href="http://www.motorhome.com/category/dinghy-towing/">Dinghy Towing</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33070"><a href="http://www.motorhome.com/submit-email-address/">Downloadable Dinghy Guides</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-38757"><a target="_blank" href="https://w1.buysub.com/pubs/RV/MHM/MHM_Subscriber_12-26-2013.jsp?cds_page_id=153971&#038;cds_mag_code=MHM">Subscribe</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-38758"><a target="_blank" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=MHM&#038;cds_page_id=153971">MotorHome Magazine</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-38759"><a href="http://www.motorhome.com/enewsletter/">MotorHome ENews!</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-38760"><a target="_blank" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=TLL&#038;cds_page_id=154023">Trailer Life Magazine</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-32070"><a href="http://www.motorhome.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_13_5d8e83387b9ed_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_5d8e83387b9ed"><script>var block_td_uid_13_5d8e83387b9ed = new tdBlock();
block_td_uid_13_5d8e83387b9ed.id = "td_uid_13_5d8e83387b9ed";
block_td_uid_13_5d8e83387b9ed.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"175","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_5d8e83387b9ed_rand","tdc_css_class":"td_uid_13_5d8e83387b9ed_rand","tdc_css_class_style":"td_uid_13_5d8e83387b9ed_rand_style"}';
block_td_uid_13_5d8e83387b9ed.td_column_number = "3";
block_td_uid_13_5d8e83387b9ed.block_type = "td_block_mega_menu";
block_td_uid_13_5d8e83387b9ed.post_count = "4";
block_td_uid_13_5d8e83387b9ed.found_posts = "231";
block_td_uid_13_5d8e83387b9ed.header_color = "";
block_td_uid_13_5d8e83387b9ed.ajax_pagination_infinite_stop = "";
block_td_uid_13_5d8e83387b9ed.max_num_pages = "58";
tdBlocksArray.push(block_td_uid_13_5d8e83387b9ed);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_5d8e83387b9ed" id="td_uid_14_5d8e83387cd38" data-td_block_id="td_uid_13_5d8e83387b9ed" data-td_filter_value="" href="http://www.motorhome.com/category/lifestyle/">All</a><a class="mega-menu-sub-cat-td_uid_13_5d8e83387b9ed" id="td_uid_15_5d8e83387cd6e" data-td_block_id="td_uid_13_5d8e83387b9ed" data-td_filter_value="599" href="http://www.motorhome.com/category/lifestyle/camp-cooking/">Camp Cooking</a><a class="mega-menu-sub-cat-td_uid_13_5d8e83387b9ed" id="td_uid_16_5d8e83387cda6" data-td_block_id="td_uid_13_5d8e83387b9ed" data-td_filter_value="598" href="http://www.motorhome.com/category/lifestyle/new-to-rving/">New To RVing</a><a class="mega-menu-sub-cat-td_uid_13_5d8e83387b9ed" id="td_uid_17_5d8e83387cdd6" data-td_block_id="td_uid_13_5d8e83387b9ed" data-td_filter_value="28" href="http://www.motorhome.com/category/lifestyle/rv-living/">RV Living</a></div></div><div id=td_uid_13_5d8e83387b9ed class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/lifestyle/rv-living/firearms-compliance-for-rvers/" rel="bookmark" class="td-image-wrap" title="Firearms Compliance for RVers"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-300x207.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-768x530.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-100x70.jpg 100w, http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-696x480.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405-609x420.jpg 609w, http://www.motorhome.com/wp-content/uploads/2019/08/Lucas-Rivest-GettyImages-178787405.jpg 1000w" sizes="(max-width: 218px) 100vw, 218px" alt="A hunter and his dog patrol the prarie" title="Firearms Compliance for RVers" /></a></div> <a href="http://www.motorhome.com/category/lifestyle/" class="td-post-category">Lifestyle</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/lifestyle/rv-living/firearms-compliance-for-rvers/" rel="bookmark" title="Firearms Compliance for RVers">Firearms Compliance for RVers</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/lifestyle/rv-living/making-your-preloved-rv-your-own-easy-upgrades-to-save-money/" rel="bookmark" class="td-image-wrap" title="Making Your Preloved RV Your Own: Easy Upgrades to Save Money"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/07/Dolphin-Exterior1-218x150.png" srcset="http://www.motorhome.com/wp-content/uploads/2019/07/Dolphin-Exterior1-218x150.png 218w, http://www.motorhome.com/wp-content/uploads/2019/07/Dolphin-Exterior1-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Motorhome parked" title="Making Your Preloved RV Your Own: Easy Upgrades to Save Money" /></a></div> <a href="http://www.motorhome.com/category/lifestyle/" class="td-post-category">Lifestyle</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/lifestyle/rv-living/making-your-preloved-rv-your-own-easy-upgrades-to-save-money/" rel="bookmark" title="Making Your Preloved RV Your Own: Easy Upgrades to Save Money">Making Your Preloved RV Your Own: Easy Upgrades to Save Money</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/lifestyle/80-terms-every-rver-needs-to-know/" rel="bookmark" class="td-image-wrap" title="80 Terms Every RVer Needs to Know"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/07/RV-lingo-bubles-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/07/RV-lingo-bubles-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/07/RV-lingo-bubles-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="RV Terms" title="80 Terms Every RVer Needs to Know" /></a></div> <a href="http://www.motorhome.com/category/lifestyle/" class="td-post-category">Lifestyle</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/lifestyle/80-terms-every-rver-needs-to-know/" rel="bookmark" title="80 Terms Every RVer Needs to Know">80 Terms Every RVer Needs to Know</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/lifestyle/rv-living/top-10-rv-campground-rules/" rel="bookmark" class="td-image-wrap" title="Top 10 RV Campground Rules"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/07/RV-Park-Etiquette-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/07/RV-Park-Etiquette-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/07/RV-Park-Etiquette-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Top 10 RV Campground Rules" /></a></div> <a href="http://www.motorhome.com/category/lifestyle/" class="td-post-category">Lifestyle</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/lifestyle/rv-living/top-10-rv-campground-rules/" rel="bookmark" title="Top 10 RV Campground Rules">Top 10 RV Campground Rules</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5d8e83387b9ed" data-td_block_id="td_uid_13_5d8e83387b9ed"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5d8e83387b9ed" data-td_block_id="td_uid_13_5d8e83387b9ed"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33064"><a href="http://www.motorhome.com/info/">Product Info</a></li>
</ul>
</li>
</ul></div></div> </div>
</div>
</div>
<div class="td-banner-wrap-full td-container-wrap ">
<div class="td-container-header td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  td_uid_18_5d8e83387f9f5_rand td_block_template_1"><script language="javascript" type="text/javascript">
OAS_url = '//oasc17.247realmedia.com/RealMedia/ads/'; OAS_sitepage ="stg.motorhome.com"; 
	permalink = window.location.pathname; OAS_listpos = 'Top'; OAS_query = ''; OAS_target = '_blank'; OAS_rn = '001234567890'; OAS_rns = '1234567890'; OAS_rn = new String (Math.random()); OAS_rns = OAS_rn.substring (2, 11);	document.write('<scr' + 'ipt src="' + OAS_url + 'adstream_mjx.ads/' + OAS_sitepage + permalink + '/1' + OAS_rns + '@' + OAS_listpos + '?' + OAS_query + '"><\/script>');
	function OAS_AD(pos) { OAS_RICH(pos); } </script>
<script>OAS_AD("Top");</script>
</div>
</div> </div>
</div>
</div>
</div><div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://www.motorhome.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Tech" class="entry-crumb" href="http://www.motorhome.com/category/tech/">Tech</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in DIY" class="entry-crumb" href="http://www.motorhome.com/category/tech/diy/">DIY</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">DIY Cargo Bay Maintenance</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-44066" class="post-44066 post type-post status-publish format-standard has-post-thumbnail hentry category-diy tag-motorhome-diy tag-motorhome-maintenance" itemscope itemtype="http://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="http://www.motorhome.com/category/tech/">Tech</a></li><li class="entry-category"><a href="http://www.motorhome.com/category/tech/diy/">DIY</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">DIY Cargo Bay Maintenance</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> E. Don Smith<div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-09-27T18:24:16+00:00">September 27, 2019</time></span> </div>
</header>
</div>
<div class="td-post-content">
<div class="td-post-featured-image"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning.jpg" data-caption=""><img width="696" height="515" class="entry-thumb td-modal-image" src="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-696x515.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-696x515.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-300x222.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-768x568.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-1024x758.jpg 1024w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-80x60.jpg 80w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-1068x790.jpg 1068w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning-568x420.jpg 568w, http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning.jpg 1200w" sizes="(max-width: 696px) 100vw, 696px" alt="cleaning and maintenance of motorhome cargo compartments" title="Compartment-door-cleaning" /></a></div>
<div style="margin-top: 0px; margin-bottom: 0px;" class="sharethis-inline-share-buttons"></div><p>&nbsp;</p>
<h2 class="p1"><span class="s1" style="color: #800000;">With the right products, tools and a little elbow grease, you can keep motorhome cargo compartments easily accessible for years to come</span></h2>
<p class="p1"><span class="s2">In 1980, Pete Townshend</span><span class="s1"> released the hit song “Let My Love Open the Door.” That was almost 40 years ago, but showing a little love to your motorhome’s cargo doors today will make them easier to open in the future. We all use our cargo bays a lot, but few of us dedicate much time or energy to maintaining them. The basement is where we store all of the outside-related camping items such as chairs, grass doormats, cleaning supplies, grills and other items that we simply can’t fit (or don’t want) inside the living quarters. When the cargo doors are properly adjusted and the weather seals are cleaned up and protected, you can enjoy many miles of trouble-free operation.</span></p>
<p class="p3">The major parts of a cargo door that require servicing are the hinges, locks, lock latches or strikers, gas springs and weather seals. The seal is the only thing that prevents moisture and road dirt from getting past the door, so you really need to take good care of them; otherwise your entire basement contents are subject to getting wet and dirty during travel.</p>
<p class="p3">We are going to show you how to clean and lubricate the hinges and locks, and clean and lubricate the weatherstripping. We will also show you how to adjust the striker latch for proper operation of the door and lock. Last, we will check all the bolts and screws to ensure the hinges and doors are tightened properly for smooth and trouble-free operation.</p>
<blockquote class="td_pull_quote td_pull_right">
<p class="p3">This project can be completed in about an hour or two, and if you work in the shade, you won&#8217;t even break a sweat!</p>
</blockquote>
<p class="p3">In order to service the doors you will need a few supplies as well as some hand tools. Most of these items you probably already have, but if not, here is what we used. First, to clean and lubricate the hinges and door locks we used a combination cleaner/lubricant. In our case, we used good ol’ WD-40 (take caution to minimize overspray on your motorhome’s skin). If your hinges are very greasy or dirty you may need to use a separate cleaner/degreaser, but for most of us WD-40 will work for both purposes.</p>
<p class="p3">For cleaning the weatherstripping we used two different products specifically for rubber. They are from Griot’s Garage and they are called Rubber Prep and Rubber Cleaner. The Rubber Cleaner is designed for normal cleaning, while the Rubber Prep is more of a deep cleaner that removes all previous silicones or old protectants that have built up. To protect and treat the rubber weatherstripping we used 303 Aerospace Protectant. We also used a special heavy-duty aluminum cleaner from Aero Cosmetics for cleaning the door skirts, and an automotive paint cleaner from Griot’s Garage called Spray-On Car Wash. There are many types of degreasers, rubber protectors and lubricants on the market, but I have tested all of these and they have proven to work great, plus we already had them “in stock” in the garage so we are sticking to what we know works.</p>
<p class="p3">Depending on the type of hinges and striker plates, you will also need some basic hand tools such as a wrench, screwdriver, pliers and maybe a socket wrench. These items will be needed to tighten the hinges and the cargo-door mounting bolts, and to adjust anything that is not perfectly aligned. This is a very easy project that should take no more than one or two hours, and if you work in the shade you will never even break a sweat.</p>
<figure id="attachment_44063" aria-describedby="caption-attachment-44063" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40.jpg"><img class="size-full wp-image-44063" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40.jpg" alt="motorhome cargo door lubrication" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-WD-40-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44063" class="wp-caption-text">Once you open each door, you should be able to identify its major components, such as the lock shown here. We sprayed it with WD-40 to clean and lubricate the mechanism. It is a good idea to open and close the lock a few times during this process by using the key and handle on the front of the door; this will help ensure that the lubrication reaches all parts of the lock.</figcaption></figure>
<figure id="attachment_44061" aria-describedby="caption-attachment-44061" style="width: 530px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-door-hinge.jpg"><img class="size-full wp-image-44061" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-door-hinge.jpg" alt="motorhome door hinge cleaning" width="530" height="800" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-door-hinge.jpg 530w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-door-hinge-199x300.jpg 199w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-door-hinge-278x420.jpg 278w" sizes="(max-width: 530px) 100vw, 530px" /></a><figcaption id="caption-attachment-44061" class="wp-caption-text">We used the same approach on the door hinge as well. The door hinges on our motorhome were not very dirty, so we simply sprayed each one with WD-40 and then wiped away the excess. If yours has a lot of grease or dirt buildup, you may need to first spray and clean with a separate degreaser.</figcaption></figure>
<figure id="attachment_44054" aria-describedby="caption-attachment-44054" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts.jpg"><img class="size-full wp-image-44054" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts.jpg" alt="cargo-door-hinge-support-bolts" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-hinge-support-bolts-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44054" class="wp-caption-text">Next, we located the hinge support bolts on the door and tightened them to ensure the door has a solid mount to the coach. Each manufacturer uses different hinges and attachment points, but you should be able to locate these bolts and tighten them with simple hand tools. This is a good time to make sure none of the bolts are missing.</figcaption></figure>
<figure id="attachment_44049" aria-describedby="caption-attachment-44049" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts.jpg"><img class="size-full wp-image-44049" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts.jpg" alt="check cargo door bolts" width="800" height="1207" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts-199x300.jpg 199w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts-768x1159.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts-679x1024.jpg 679w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts-696x1050.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-bolts-278x420.jpg 278w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44049" class="wp-caption-text">Here are the bolts located on the inside of the hinge that also need to be checked and/or tightened. In our case, about 50-60 percent of the bolts we checked were loose. After years of use and bumping down the road this is not uncommon, so double-check all the bolts to make sure they are tight.</figcaption></figure>
<figure id="attachment_44053" aria-describedby="caption-attachment-44053" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket.jpg"><img class="size-full wp-image-44053" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket.jpg" alt="cargo-door-gas-spring-bracket" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-gas-spring-bracket-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44053" class="wp-caption-text">We also checked both ends of the gas-spring bracket to ensure those bolts were tight as well. The other end of the spring is connected to a bracket inside of the cargo bay, so make sure you check it too.</figcaption></figure>
<figure id="attachment_44050" aria-describedby="caption-attachment-44050" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging.jpg"><img class="size-full wp-image-44050" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging.jpg" alt="cargo-door-check-lock-engaging" width="800" height="603" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging-300x226.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging-768x579.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging-80x60.jpg 80w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging-696x525.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-lock-engaging-557x420.jpg 557w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44050" class="wp-caption-text">While your tools are out, check each door to ensure the lock is properly engaging the striker pin or plate. Each manufacturer uses a different mechanism, but the principle is the same. The inside of the lock will strike and engage a pin or plate, and that is what holds the door closed. When properly adjusted, the pin will perfectly enter the lock as the lock hasp closes around the pin. If the pin is improperly adjusted the result will be a door that is difficult to open or close.</figcaption></figure>
<figure id="attachment_44055" aria-describedby="caption-attachment-44055" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly.jpg"><img class="size-full wp-image-44055" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly.jpg" alt="cargo-door-latch-assembly" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-latch-assembly-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44055" class="wp-caption-text">There are two ways to repair an improperly adjusted door-latch assembly. One is to adjust the striker pin/plate as shown here. You can see there are adjustment slots in the plate that allow you to loosen the bolts and then move the plate to get it in the correct position to be engaged by the door lock.</figcaption></figure>
<figure id="attachment_44062" aria-describedby="caption-attachment-44062" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin.jpg"><img class="size-full wp-image-44062" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin.jpg" alt="cargo door adjustment" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-tweaking-striker-pin-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44062" class="wp-caption-text">If your door lock is only slightly out of adjustment, you can “encourage” it into place by tweaking the striker pin slightly up/down or left/right as needed for proper engagement. Though a bit crude, it is often the best way to make a minor adjustment.</figcaption></figure>
<figure id="attachment_44048" aria-describedby="caption-attachment-44048" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment.jpg"><img class="size-full wp-image-44048" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment.jpg" alt="check cargo door alignment" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-check-alignment-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44048" class="wp-caption-text">As you inspect, clean and adjust each door, it is also a good time to check for proper alignment. The edge of the door along the top relative to the RV frame — as well as the side edges — should be parallel to the part next to it, and the door should not rub anywhere. If you find misalignment you may have to adjust the door position on the coach. Each motorhome is different, and some models may be user-adjustable, while others may require the services of a technician at an RV service center.</figcaption></figure>
<figure id="attachment_44057" aria-describedby="caption-attachment-44057" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner.jpg"><img class="size-full wp-image-44057" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner.jpg" alt="rubber cleaner" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-cleaner-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44057" class="wp-caption-text">The weatherstripping is the only thing protecting the contents of your basement from the outside elements, so you need to take good care of it. We started by cleaning each one with Griot’s Rubber Cleaner. Simply spray it on and wipe it off with a clean microfiber towel. If the rubber is in really bad shape, Griot’s Garage also offers a Rubber Prep product that completely strips off all old cleaners and lingering oil or silicones that may be present. This better prepares the rubber for the next step.</figcaption></figure>
<figure id="attachment_44058" aria-describedby="caption-attachment-44058" style="width: 811px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep.jpg"><img class="size-full wp-image-44058" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep.jpg" alt="rubber prep" width="811" height="538" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep.jpg 811w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep-696x462.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-rubber-prep-633x420.jpg 633w" sizes="(max-width: 811px) 100vw, 811px" /></a><figcaption id="caption-attachment-44058" class="wp-caption-text">The Rubber Prep product is applied by wiping the seals with a foam sponge that was soaked with the cleaner. This completely strips off the old cleaners and silicone residue often left behind by other protectants.</figcaption></figure>
<figure id="attachment_44060" aria-describedby="caption-attachment-44060" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303.jpg"><img class="size-full wp-image-44060" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303.jpg" alt="303 Aerospace Protectant" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-spraying-303-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44060" class="wp-caption-text">Once the rubber weatherstripping is completely clean, it is time to apply the 303 Aerospace Protectant. Simply spray it on then wipe it dry with a clean microfiber towel. This is a great product and, unlike many “tire and rubber” protectants, it does not contain any ingredients (petroleum distillates) that accelerate the wear or deteriorate delicate rubber seals.</figcaption></figure>
<figure id="attachment_44045" aria-describedby="caption-attachment-44045" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray.jpg"><img class="size-full wp-image-44045" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray.jpg" alt="wiping excess spray" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-303-spray-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44045" class="wp-caption-text">Once you wipe off the excess 303 spray, you will be rewarded with a rich-looking seal that is well-protected. We have used this product for years, and it has never failed to do a great job.</figcaption></figure>
<figure id="attachment_44056" aria-describedby="caption-attachment-44056" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber.jpg"><img class="size-full wp-image-44056" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber.jpg" alt="cleaning springs" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-microfiber-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44056" class="wp-caption-text">We also took this opportunity to spray some WD-40 on each of the gas springs and then wipe them down. Pay particular attention to the piston portion of the assembly that goes in and out of the shock during operation. This will help eliminate the chance of dirt and grime getting into the seals and damaging them.</figcaption></figure>
<figure id="attachment_44059" aria-describedby="caption-attachment-44059" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash.jpg"><img class="size-full wp-image-44059" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash.jpg" alt="cleaning cargo channel" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-Spray-on-car-wash-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44059" class="wp-caption-text">This particular door design has a U-shaped channel on top that serves as a trap for dirt and grime. If a job is worth doing it’s worth doing right, so let’s clean that out as well. We used an automotive cleaning product called Spray-On Car Wash from Griot’s, and it does a great job of cleaning without any chance of damaging the paint.</figcaption></figure>
<figure id="attachment_44047" aria-describedby="caption-attachment-44047" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel.jpg"><img class="size-full wp-image-44047" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel.jpg" alt="wiping cargo channel" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-channel-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44047" class="wp-caption-text">After spraying it, you can wipe away all the dirt and grime with a clean microfiber towel, and the aluminum channel now looks new.</figcaption></figure>
<figure id="attachment_44046" aria-describedby="caption-attachment-44046" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash.jpg"><img class="size-full wp-image-44046" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash.jpg" alt="Belly Wash" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-belly-wash-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44046" class="wp-caption-text">The last step in this process is the bottom of the cargo door. This skirt is on the inside bottom of each door and since it wraps under the coach and is exposed to the road, it gets very dirty. We used Aero Cosmetics Belly Wash, which is specifically designed for aluminum aircraft parts.</figcaption></figure>
<figure id="attachment_44052" aria-describedby="caption-attachment-44052" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash.jpg"><img class="size-full wp-image-44052" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash.jpg" alt="scrubbing cargo bay" width="800" height="530" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash.jpg 800w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaning-with-belly-wash-634x420.jpg 634w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption id="caption-attachment-44052" class="wp-caption-text">After spraying on the Belly Wash, a scrubber pad from Aero Cosmetics was used to cut through years of dirt and abuse. Note, this product is very concentrated and should only be used on certain areas, such as this unpainted aluminum skirt. Be sure to rinse well with water after cleaning.</figcaption></figure>
<figure id="attachment_44051" aria-describedby="caption-attachment-44051" style="width: 825px" class="wp-caption aligncenter"><a href="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned.jpg"><img class="size-full wp-image-44051" src="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned.jpg" alt="clean cargo bay" width="825" height="547" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned.jpg 825w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned-300x199.jpg 300w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned-768x509.jpg 768w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned-696x461.jpg 696w, http://www.motorhome.com/wp-content/uploads/2019/09/cargo-door-cleaned-633x420.jpg 633w" sizes="(max-width: 825px) 100vw, 825px" /></a><figcaption id="caption-attachment-44051" class="wp-caption-text">The end result is a clean compartment bay!</figcaption></figure>
<hr />
<p>&nbsp;</p>
<div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div class="td-all-devices">
<script language="javascript" type="text/javascript">
OAS_url = '//oasc17.247realmedia.com/RealMedia/ads/'; OAS_sitepage ="stg.motorhome.com"; 
	permalink = window.location.pathname; OAS_listpos = 'Middle1'; OAS_query = ''; OAS_target = '_blank'; OAS_rn = '001234567890'; OAS_rns = '1234567890'; OAS_rn = new String (Math.random()); OAS_rns = OAS_rn.substring (2, 11);	document.write('<scr' + 'ipt src="' + OAS_url + 'adstream_mjx.ads/' + OAS_sitepage + permalink + '/1' + OAS_rns + '@' + OAS_listpos + '?' + OAS_query + '"><\/script>');
	function OAS_AD(pos) { OAS_RICH(pos); } </script>
<script>OAS_AD("Middle1");</script>
</div></div>
</div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://www.motorhome.com/tag/motorhome-diy/">Motorhome DIY</a></li><li><a href="http://www.motorhome.com/tag/motorhome-maintenance/">motorhome maintenance</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="E. Don Smith"></span><meta itemprop="datePublished" content="2019-09-27T18:24:16+00:00"><meta itemprop="dateModified" content="2019-09-27T18:24:16-03:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.motorhome.com/tech/diy/diy-cargo-bay-maintenance/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.motorhome.com/wp-content/uploads/2017/09/MotorHome-logo-white-373x80-300x64.png"></span><meta itemprop="name" content="MotorHome Magazine"></span><meta itemprop="headline " content="DIY Cargo Bay Maintenance"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.motorhome.com/wp-content/uploads/2019/09/Compartment-door-cleaning.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="888"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts td_uid_20_5d8e833885cf6_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_20_5d8e833885cf6"><script>var block_td_uid_20_5d8e833885cf6 = new tdBlock();
block_td_uid_20_5d8e833885cf6.id = "td_uid_20_5d8e833885cf6";
block_td_uid_20_5d8e833885cf6.atts = '{"limit":9,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"td_uid_20_5d8e833885cf6_rand","td_column_number":3,"live_filter_cur_post_id":44066,"live_filter_cur_post_author":"5","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_20_5d8e833885cf6_rand","tdc_css_class_style":"td_uid_20_5d8e833885cf6_rand_style"}';
block_td_uid_20_5d8e833885cf6.td_column_number = "3";
block_td_uid_20_5d8e833885cf6.block_type = "td_block_related_posts";
block_td_uid_20_5d8e833885cf6.post_count = "9";
block_td_uid_20_5d8e833885cf6.found_posts = "102";
block_td_uid_20_5d8e833885cf6.header_color = "";
block_td_uid_20_5d8e833885cf6.ajax_pagination_infinite_stop = "";
block_td_uid_20_5d8e833885cf6.max_num_pages = "12";
tdBlocksArray.push(block_td_uid_20_5d8e833885cf6);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_21_5d8e833887fbc" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_20_5d8e833885cf6" href="#">RELATED ARTICLES</a><a id="td_uid_22_5d8e833887fc1" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_20_5d8e833885cf6" href="#">More from MotorHome</a></h4><div id=td_uid_20_5d8e833885cf6 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/top-stories/lifting-the-fog/" rel="bookmark" class="td-image-wrap" title="Lifting the Fog"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/dual-pane-windows-lead1-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/dual-pane-windows-lead1-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/dual-pane-windows-lead1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Motorhome window frames a foggy landscape" title="Lifting the Fog" /></a></div> <a href="http://www.motorhome.com/category/tech/" class="td-post-category">Tech</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/top-stories/lifting-the-fog/" rel="bookmark" title="Lifting the Fog">Lifting the Fog</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/diy/cool-runnings/" rel="bookmark" class="td-image-wrap" title="Cool Runnings"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/09/Cool-Runnings-Lead-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/09/Cool-Runnings-Lead-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/09/Cool-Runnings-Lead-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="the author and his coach" title="Cool Runnings" /></a></div> <a href="http://www.motorhome.com/category/tech/diy/" class="td-post-category">DIY</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/diy/cool-runnings/" rel="bookmark" title="Cool Runnings">Cool Runnings</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/royal-flush/" rel="bookmark" class="td-image-wrap" title="Royal Flush"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/07/THETFORD-AQUA-MAGIC-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/07/THETFORD-AQUA-MAGIC-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/07/THETFORD-AQUA-MAGIC-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Photo of RV toilet" title="Royal Flush" /></a></div> <a href="http://www.motorhome.com/category/tech/" class="td-post-category">Tech</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/royal-flush/" rel="bookmark" title="Royal Flush">Royal Flush</a></h3> </div>
</div>
</div> </div>
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/rv-tech-questions/rv-tech-savvy-daytime-running-lights-dont/" rel="bookmark" class="td-image-wrap" title="RV Tech Savvy: Daytime Running Lights … Don’t"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/07/lights-icon-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/07/lights-icon-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/07/lights-icon-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Headlight Graphic i to illustrate article on daytime running lights" title="RV Tech Savvy: Daytime Running Lights … Don’t" /></a></div> <a href="http://www.motorhome.com/category/tech/rv-tech-questions/" class="td-post-category">RV Tech Q&amp;A</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/rv-tech-questions/rv-tech-savvy-daytime-running-lights-dont/" rel="bookmark" title="RV Tech Savvy: Daytime Running Lights … Don’t">RV Tech Savvy: Daytime Running Lights … Don’t</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/diy/how-to-remove-water-spots-on-an-rv/" rel="bookmark" class="td-image-wrap" title="How to Remove Water Spots on an RV"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/07/shurhold-water-spots-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/07/shurhold-water-spots-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/07/shurhold-water-spots-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Shurhold Water Spot Removal" title="How to Remove Water Spots on an RV" /></a></div> <a href="http://www.motorhome.com/category/tech/diy/" class="td-post-category">DIY</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/diy/how-to-remove-water-spots-on-an-rv/" rel="bookmark" title="How to Remove Water Spots on an RV">How to Remove Water Spots on an RV</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/diy/motorhome-battery-upgrade-2/" rel="bookmark" class="td-image-wrap" title="Motorhome Battery Upgrade"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/06/battery-lead-2-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/06/battery-lead-2-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/06/battery-lead-2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Photo of motorhome batteries to illustrate battery upgrade article" title="Motorhome Battery Upgrade" /></a></div> <a href="http://www.motorhome.com/category/tech/diy/" class="td-post-category">DIY</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/diy/motorhome-battery-upgrade-2/" rel="bookmark" title="Motorhome Battery Upgrade">Motorhome Battery Upgrade</a></h3> </div>
</div>
</div> </div>
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/rv-tech-questions/rv-tech-savvy-tire-compounds-revisited/" rel="bookmark" class="td-image-wrap" title="Rv Tech Savvy: Tire Compounds — Revisited"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/06/CP-Tires-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/06/CP-Tires-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/06/CP-Tires-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Photo of tires to go with tech Q&amp;A article" title="Rv Tech Savvy: Tire Compounds — Revisited" /></a></div> <a href="http://www.motorhome.com/category/tech/rv-tech-questions/" class="td-post-category">RV Tech Q&amp;A</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/rv-tech-questions/rv-tech-savvy-tire-compounds-revisited/" rel="bookmark" title="Rv Tech Savvy: Tire Compounds — Revisited">Rv Tech Savvy: Tire Compounds — Revisited</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/rv-tech-questions/rv-tech-savvy-more-electric-vehicle-questions/" rel="bookmark" class="td-image-wrap" title="Rv Tech Savvy: More Electric Vehicle Questions"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/05/CP-electric-vehicle-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/05/CP-electric-vehicle-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/05/CP-electric-vehicle-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Graphic illustration of electic vehicle icon" title="Rv Tech Savvy: More Electric Vehicle Questions" /></a></div> <a href="http://www.motorhome.com/category/tech/rv-tech-questions/" class="td-post-category">RV Tech Q&amp;A</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/rv-tech-questions/rv-tech-savvy-more-electric-vehicle-questions/" rel="bookmark" title="Rv Tech Savvy: More Electric Vehicle Questions">Rv Tech Savvy: More Electric Vehicle Questions</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/quick-tips/motorhome-quick-tip-name-that-slideout/" rel="bookmark" class="td-image-wrap" title="Motorhome Quick Tip: Name That Slideout"><img width="218" height="150" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2019/04/Slide-Bar-218x150.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2019/04/Slide-Bar-218x150.jpg 218w, http://www.motorhome.com/wp-content/uploads/2019/04/Slide-Bar-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="illustration of hanging tage to remind RV owners to remove slide bar" title="Motorhome Quick Tip: Name That Slideout" /></a></div> <a href="http://www.motorhome.com/category/tech/quick-tips/" class="td-post-category">Quick Tips</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/quick-tips/motorhome-quick-tip-name-that-slideout/" rel="bookmark" title="Motorhome Quick Tip: Name That Slideout">Motorhome Quick Tip: Name That Slideout</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5d8e833885cf6" data-td_block_id="td_uid_20_5d8e833885cf6"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_20_5d8e833885cf6" data-td_block_id="td_uid_20_5d8e833885cf6"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/tech/diy/diy-cargo-bay-maintenance/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="http://www.motorhome.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div>
<div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='44066' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c3b70f0377" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="57" /></p> </form>
</div>
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><script language="javascript" type="text/javascript">
OAS_url = '//oasc17.247realmedia.com/RealMedia/ads/'; OAS_sitepage ="stg.motorhome.com"; 
	permalink = window.location.pathname; OAS_listpos = 'x01,x02,x03,Right1,Right2'; OAS_query = ''; OAS_target = '_blank'; OAS_rn = '001234567890'; OAS_rns = '1234567890'; OAS_rn = new String (Math.random()); OAS_rns = OAS_rn.substring (2, 11);	document.write('<scr' + 'ipt src="' + OAS_url + 'adstream_mjx.ads/' + OAS_sitepage + permalink + '/1' + OAS_rns + '@' + OAS_listpos + '?' + OAS_query + '"><\/script>');
	function OAS_AD(pos) { OAS_RICH(pos); } </script>
<div class="td-all-devices">
<script>OAS_AD("Right1");</script>
</div></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><style>
	.td-a-rec-id-custom_ad_4{
		float: left;
	} 
	.ad-content img{
		margin:0 auto 20px;
	}
</style>
<div class="ad-content" style="margin-bottom: 40px;">
<div class="wpb_text_column wpb_content_element block-title">
<div class="wpb_wrapper">
<h4><strong>IN THE SPOTLIGHT</strong></h4>
</div>
</div>
<div>
<script>OAS_AD('x01');</script>
</div>
<div class="wpb_text_column wpb_content_element block-title">
<div class="wpb_wrapper">
<h4><strong> </strong></h4>
</div>
</div>
<div>
<script>OAS_AD('x02');</script>
</div>
<div class="wpb_text_column wpb_content_element block-title">
<div class="wpb_wrapper">
<h4><strong></strong></h4>
</div>
</div>
<div>
<script>OAS_AD('x03');</script>
</div>
</div></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="td-all-devices">
<script>OAS_AD("Right2");</script>
</div></div></aside> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-container-wrap td-footer-template-3 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://www.motorhome.com/"><img src="http://www.motorhome.com/wp-content/uploads/2017/09/MotorHome-logo-white-373x80-300x64.png" alt="MotorHome Magazine" title="Travel, Tech, Lifestyle for the RV Enthusiast" /></a></div><div class="footer-text-wrap">Find new motorhome tests and reviews, dinghy towing info, motorhome tips, RV camping gear and RV DIY projects at MotorHome magazine.</div><div class="footer-social-wrap td-social-style-2"></div></div><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"></div>
</aside> </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div style="font-size: 24px; font-weight: bold; line-height: normal;">Get a FREE issue of MotorHome magazine</div>
<p>Sign up for your trial subscription and you&#8217;ll receive a FREE issue. If you like MotorHome, pay just $19.97 for 11 more issues (12 in all). Otherwise, write &#8220;cancel&#8221; on the invoice, return it and owe nothing.</p>
<p><a href="https://w1.buysub.com/pubs/RV/MHM/MHM_Free_Sub.jsp?cds_page_id=69273&amp;cds_mag_code=MHM&amp;id=1509992081901&amp;lsid=73101213382031872&amp;vid=3&amp;send=Subscribe+Now%21&amp;cds_response_key=TMMDEMB"><img class="alignnone" src="http://www.motorhome.com/wp-content/uploads/2018/07/GetYourFreeIssue3.png" alt="Get Your Free Issue logo" width="320" height="47" /></a></p>
</div>
</aside> </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><img class="aligncenter" src="http://www.motorhome.com/wp-content/uploads/2017/09/Motorhome-Mag-Subscribe-220pxH.png" alt="Subscribe to Motorhome" width="189" height="220" /></p>
</div>
</aside> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-sub-footer-menu-container"><ul id="menu-sub-footer-menu" class="td-subfooter-menu"><li id="menu-item-44019" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-44019"><a target="_blank" rel="noopener noreferrer" href="http://www.motorhome.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-44020" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-44020"><a target="_blank" rel="noopener noreferrer" href="http://www.motorhome.com/terms-of-use/">Terms of Use</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; 2019 Good Sam Enterprises, LLC. All Rights Reserved. </div>
</div>
</div>
</div>
</div>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.motorhome.com/tech/quick-tips/get-your-foot-in-the-door/" rel="bookmark" class="td-image-wrap" title="Get Your Foot in the Door"><img width="100" height="70" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2016/06/QT-Shoe-Holder-1-100x70.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2016/06/QT-Shoe-Holder-1-100x70.jpg 100w, http://www.motorhome.com/wp-content/uploads/2016/06/QT-Shoe-Holder-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Quick Tips - Shoe Holder" title="Get Your Foot in the Door" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/tech/quick-tips/get-your-foot-in-the-door/" rel="bookmark" title="Get Your Foot in the Door">Get Your Foot in the Door</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-06-29T11:14:03+00:00">June 29, 2016</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.motorhome.com/motorhomes/gear-reviews/squeaky-clean/" rel="bookmark" class="td-image-wrap" title="Squeaky Clean"><img width="100" height="70" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2016/09/DSC_0864-100x70.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2016/09/DSC_0864-100x70.jpg 100w, http://www.motorhome.com/wp-content/uploads/2016/09/DSC_0864-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Spotless Water Station" title="Squeaky Clean" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/motorhomes/gear-reviews/squeaky-clean/" rel="bookmark" title="Squeaky Clean">Squeaky Clean</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-20T12:30:00+00:00">September 20, 2016</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.motorhome.com/uncategorized/installing-an-lsl-amp-l-start-chassis-battery-charger/" rel="bookmark" class="td-image-wrap" title="Installing an LSL AMP-L-START chassis-battery charger"><img width="100" height="70" class="entry-thumb" src="http://www.motorhome.com/wp-content/uploads/2016/12/Battery-Charger-lead-1-100x70.jpg" srcset="http://www.motorhome.com/wp-content/uploads/2016/12/Battery-Charger-lead-1-100x70.jpg 100w, http://www.motorhome.com/wp-content/uploads/2016/12/Battery-Charger-lead-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Battery lead picture" title="Installing an LSL AMP-L-START chassis-battery charger" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.motorhome.com/uncategorized/installing-an-lsl-amp-l-start-chassis-battery-charger/" rel="bookmark" title="Installing an LSL AMP-L-START chassis-battery charger">Installing an LSL AMP-L-START chassis-battery charger</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-12-13T19:29:51+00:00">December 13, 2016</time></span> </div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">
/* custom css theme panel */
/* default margin-right:42px Changed to allow for larger font on menu */
.td-header-style-6 .td-main-menu-logo {
    margin-right:10px;
}

.sf-menu a.sf-with-ul {
    padding-right:20px;
}

/* .td-header-menu-wrap-full { */
    /* background: rgb(84,71,65); */ /* Old browsers */
    /* background: -moz-linear-gradient(top, rgb(84,71,65) 0%, rgb(28,24,23) 100%); */ /* FF3.6-15 */
    /* background: -webkit-linear-gradient(top, rgb(84,71,65) 0%,rgb(28,24,23) 100%); */ /* Chrome10-25,Safari5.1-6 */
    /* background: linear-gradient(to bottom, rgb(84,71,65) 0%,rgb(28,24,23) 100%); */ /* W3C, IE10+, FF16+, Chrome26+, Opera12+, Safari7+ */
    /* filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#544741', endColorstr='#1c1817',GradientType=0 ); */ /* IE6-9 */
/* } */

.centerad{
    
    text-align:center;
    
}

.td-trending-now-title {
    color:white;
}

.td-module-comments {
    display:none;
}

.menu-item-41829 > a
{
    font-size:12px!important;
 
}

.sf-menu ul .menu-item-41829 >a {
    padding: 7px 15px!important;

}


.menu-item-41829
{
    font-weight:bold;  
   
}

</style>
<link rel='stylesheet' id='wppcp_front_css-css' href='http://www.motorhome.com/wp-content/plugins/wp-private-content-plus/css/wppcp-front.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='slideshow-satellite_styleStatic-css' href='http://www.motorhome.com/wp-content/plugins/slideshow-satellite/css/orbit-1.3.1.css?v=2.4&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='slideshow-satellite_style-css' href='http://www.motorhome.com/wp-content/plugins/slideshow-satellite/css/orbit-css.php?v=2.4&#038;pID=23497&#038;width=450&#038;height=300&#038;thumbheight=75&#038;thumbarea=275&#038;thumbareamargin=30&#038;thumbmargin=2&#038;thumbspacing=5&#038;thumbactive=%23FFFFFF&#038;thumbopacity=70&#038;align=none&#038;border=1px+solid+%23CCCCCC&#038;background=%23000000&#038;infotitle=2&#038;infobackground=%23000000&#038;infocolor=%23FFFFFF&#038;playshow=A&#038;nav_opacity=30&#038;navpush=0&#038;infomin=Y&#038;ver=5.2.3' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.motorhome.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.motorhome.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.4'></script>
<script type='text/javascript' src='http://www.motorhome.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.7.3'></script>
<script type='text/javascript' src='http://www.motorhome.com/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.motorhome.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.motorhome.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script async="async" type='text/javascript' src='http://www.motorhome.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='http://www.motorhome.com/wp-content/plugins/slideshow-satellite/js/orbit-min.js?ver=2.4'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://www.motorhome.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://www.motorhome.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
<header>
<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
</header>
<div class="tdw-content">
<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">
<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>
<textarea class="tdw-css-writer-editor td_live_css_uid_1_5d8e833895ceb"></textarea>
<div id="td_live_css_uid_1_5d8e833895ceb" class="td-code-editor"></div>
<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5d8e833895ceb');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5d8e833895ceb");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>
</div>
</div>
<footer>
<a href="#" class="tdw-save-css">Save</a>
<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>
<div class="tdw-resize"></div>
</footer>
</div>
</body>
</html>
