Got the Vapors, Too

December 14, 2012
Filed under RV Tech Q&A

Bookmark and Share

I was intrigued by part of your answer to the October “Got the ‘Vapors’” letter. It relates to the fuel pump. I have a 1997 Fleetwood Tioga Walkabout built on a Ford chassis with a Triton V-10 engine. The original fuel pump lasted until January 2008. The next one I had put in (a cheapie) lasted until September 2009. Then I had an O’Reilly brand put in, which lasted all of nine months. The last one was a Motorcraft (part number PFS66 — cost $469). It ran for 22 months and now has quit working. Any ideas what could be is causing these fuel pump failures?
Glenn McCoy l Portales, N.M.

The frequency of failures leads me to think that perhaps something in the fuel or tank is affecting the pumps. Has the tank been flushed? Fine sand or some other substance may be in the tank. I usually take apart failed components to look inside and try to determine why they quit. I suggest you try an original (updated) Ford part on the next go around, and inspect failed parts. Of course, replace fuel filters regularly, too.
– Ken Freund


Have a technical question about your RV? Send them to Tech@MotorHomeMagazine.com. Also, check out TrailerLife.TV for expert RV how-to videos.

Print Friendly

Related Content

Last 5 stories in RV Tech Q&A

Other stories that might interest you...

Comments

Feel free to leave a comment...
and oh, if you want a pic to show with your comment, go get a gravatar!





Get a FREE issue of Motor Home Magazine

Sign up for your trial subscription and you'll receive a FREE issue. If you like Motor Home, pay just $19.97 for 11 more issues (12 in all). Otherwise, write "cancel" on the invoice, return it and owe nothing.